
<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://poolmag.com/xmlrpc.php" />
<title>Predator World 10-Ball March 16-20 - Pool &amp; Billiard Magazine</title>

<!-- This site is optimized with the Yoast SEO plugin v13.0 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="http://poolmag.com/predator-world-10-ball-rio-all-suites-hotel-casino-las-vegas-march-16-20/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Predator World 10-Ball March 16-20 - Pool &amp; Billiard Magazine" />
<meta property="og:description" content="Predator World 10-Ball, Rio All-Suites Hotel Casino, Las Vegas March 16-20 Last year, Ping-Chung Ko claimed his first World Championship with a dramatic win in the finals over Joshua Filler. This was part of his incredible 2019, which earned him" />
<meta property="og:url" content="http://poolmag.com/predator-world-10-ball-rio-all-suites-hotel-casino-las-vegas-march-16-20/" />
<meta property="og:site_name" content="Pool &amp; Billiard Magazine" />
<meta property="article:tag" content="predator world 10-ball" />
<meta property="article:section" content="Pool and Billiard Tournament News" />
<meta property="article:published_time" content="2020-02-21T12:10:37+00:00" />
<meta property="article:modified_time" content="2020-02-21T12:12:27+00:00" />
<meta property="og:updated_time" content="2020-02-21T12:12:27+00:00" />
<meta property="og:image" content="http://poolmag.com/wp-content/uploads/2020/02/PR-photo.jpeg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="800" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Predator World 10-Ball, Rio All-Suites Hotel Casino, Las Vegas March 16-20 Last year, Ping-Chung Ko claimed his first World Championship with a dramatic win in the finals over Joshua Filler. This was part of his incredible 2019, which earned him" />
<meta name="twitter:title" content="Predator World 10-Ball March 16-20 - Pool &amp; Billiard Magazine" />
<meta name="twitter:image" content="http://poolmag.com/wp-content/uploads/2020/02/PR-photo.jpeg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"http://poolmag.com/#website","url":"http://poolmag.com/","name":"Pool &amp; Billiard Magazine","description":"The original monthly magazine for cue sports","potentialAction":{"@type":"SearchAction","target":"http://poolmag.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"http://poolmag.com/predator-world-10-ball-rio-all-suites-hotel-casino-las-vegas-march-16-20/#primaryimage","url":"http://poolmag.com/wp-content/uploads/2020/02/PR-photo.jpeg","width":1200,"height":800},{"@type":"WebPage","@id":"http://poolmag.com/predator-world-10-ball-rio-all-suites-hotel-casino-las-vegas-march-16-20/#webpage","url":"http://poolmag.com/predator-world-10-ball-rio-all-suites-hotel-casino-las-vegas-march-16-20/","inLanguage":"en-US","name":"Predator World 10-Ball March 16-20 - Pool &amp; Billiard Magazine","isPartOf":{"@id":"http://poolmag.com/#website"},"primaryImageOfPage":{"@id":"http://poolmag.com/predator-world-10-ball-rio-all-suites-hotel-casino-las-vegas-march-16-20/#primaryimage"},"datePublished":"2020-02-21T12:10:37+00:00","dateModified":"2020-02-21T12:12:27+00:00","author":{"@id":"http://poolmag.com/#/schema/person/92f28fbda971024add8196ecc45f86dc"}},{"@type":["Person"],"@id":"http://poolmag.com/#/schema/person/92f28fbda971024add8196ecc45f86dc","name":"Harold Simonsen","image":{"@type":"ImageObject","@id":"http://poolmag.com/#authorlogo","url":"http://0.gravatar.com/avatar/c878ec4179c68bc4fcb16967e76d3b60?s=96&d=mm&r=g","caption":"Harold Simonsen"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<meta http-equiv="x-dns-prefetch-control" content="on">
<link href="https://app.ecwid.com" rel="preconnect" crossorigin />
<link href="https://ecomm.events" rel="preconnect" crossorigin />
<link href="https://d1q3axnfhmyveb.cloudfront.net" rel="preconnect" crossorigin />
<link href="https://dqzrr9k4bjpzk.cloudfront.net" rel="preconnect" crossorigin />
<link href="https://d3j0zfs7paavns.cloudfront.net" rel="preconnect" crossorigin>
<link rel="prefetch" href="https://app.ecwid.com/script.js?7055210&data_platform=wporg&lang=en&data_g=0000000000" />
<link rel="prerender" href="http://poolmag.com/subscribe/" />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//k4z6w9b5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//go.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="Pool &amp; Billiard Magazine &raquo; Feed" href="http://poolmag.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Pool &amp; Billiard Magazine &raquo; Comments Feed" href="http://poolmag.com/comments/feed/" />
<!-- Powered by Shareaholic; Grow your Audience faster! - https://www.shareaholic.com -->
<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script'/>
<script data-no-minify='1' data-cfasync='false'>
  //<![CDATA[
    _SHR_SETTINGS = {"endpoints":{"local_recs_url":"http:\/\/poolmag.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"http:\/\/poolmag.com\/wp-admin\/admin-ajax.php","share_counts_url":"http:\/\/poolmag.com\/wp-admin\/admin-ajax.php?action=shareaholic_share_counts_api"},"site_id":"499d96628d570438e39aa7a5fd7bfb30","url_components":{"year":"2020","monthnum":"02","day":"21","hour":"07","minute":"10","second":"37","post_id":"5753","postname":"predator-world-10-ball-rio-all-suites-hotel-casino-las-vegas-march-16-20","category":"pool-and-billiard-tournament-news"}};
  //]]>
</script>
<script data-no-minify='1' data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='499d96628d570438e39aa7a5fd7bfb30' async ></script>
<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='Pool &amp; Billiard Magazine' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='http://poolmag.com/predator-world-10-ball-rio-all-suites-hotel-casino-las-vegas-march-16-20/' />
<meta name='shareaholic:keywords' content='tag:predator world 10-ball, cat:pool and billiard tournament news, type:post' />
<meta name='shareaholic:article_published_time' content='2020-02-21T07:10:37-05:00' />
<meta name='shareaholic:article_modified_time' content='2020-02-21T07:12:27-05:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Harold Simonsen' />
<meta name='shareaholic:site_id' content='499d96628d570438e39aa7a5fd7bfb30' />
<meta name='shareaholic:wp_version' content='8.13.13' />
<meta name='shareaholic:image' content='http://poolmag.com/wp-content/uploads/2020/02/PR-photo-640x427.jpeg' />
<!-- Shareaholic Content Tags End -->
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.10.4 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.10.4';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-4791367-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-4791367-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('set', 'anonymizeIp', true);
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/poolmag.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='http://poolmag.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='ecwid-css-css'  href='http://poolmag.com/wp-content/plugins/ecwid-shopping-cart/css/frontend.css?ver=6.8.11' type='text/css' media='all' />
<link rel='stylesheet' id='social-widget-css'  href='http://poolmag.com/wp-content/plugins/social-media-widget/social_widget.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox.css-css'  href='http://poolmag.com/wp-includes/js/thickbox/thickbox.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://poolmag.com/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='http://poolmag.com/wp-includes/js/thickbox/thickbox.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='spacious_style-css'  href='http://poolmag.com/wp-content/themes/PoolBilliardChild/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='spacious-genericons-css'  href='http://poolmag.com/wp-content/themes/spacious/genericons/genericons.css?ver=3.3' type='text/css' media='all' />
<link rel='stylesheet' id='google_fonts-css'  href='//fonts.googleapis.com/css?family=Lato&#038;ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='footer-credits-css'  href='http://poolmag.com/wp-content/plugins/footer-putter/styles/footer-credits.css?ver=1.16' type='text/css' media='all' />
<link rel='stylesheet' id='mc4wp-form-basic-css'  href='http://poolmag.com/wp-content/plugins/mailchimp-for-wp/assets/css/form-basic.min.css?ver=4.7.4' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"http:\/\/poolmag.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='http://poolmag.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.10.4'></script>
<script type='text/javascript' src='http://poolmag.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='http://poolmag.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ecwidParams = {"useJsApiToOpenStoreCategoriesPages":"","trackPublicPage":"1","storeId":"7055210"};
/* ]]> */
</script>
<script type='text/javascript' src='http://poolmag.com/wp-content/plugins/ecwid-shopping-cart/js/frontend.js?ver=6.8.11'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var samAjax = {"ajaxurl":"http:\/\/poolmag.com\/wp-content\/plugins\/simple-ads-manager\/sam-ajax.php","loadurl":"http:\/\/poolmag.com\/wp-content\/plugins\/simple-ads-manager\/sam-ajax-loader.php","load":"","mailer":"1","clauses":"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","doStats":"1","container":"sam-container","place":"sam-place","ad":"sam-ad"};
/* ]]> */
</script>
<script type='text/javascript' src='http://poolmag.com/wp-content/plugins/simple-ads-manager/js/sam-layout.min.js?ver=2.9.6.121'></script>
<script type='text/javascript' src='http://poolmag.com/wp-content/themes/spacious/js/spacious-custom.js?ver=5.3.2'></script>
<script type='text/javascript' src='http://poolmag.com/wp-content/plugins/spider-event-calendar/elements/calendar.js?ver=2.5.18'></script>
<script type='text/javascript' src='http://poolmag.com/wp-content/plugins/spider-event-calendar/elements/calendar-setup.js?ver=2.5.18'></script>
<script type='text/javascript' src='http://poolmag.com/wp-content/plugins/spider-event-calendar/elements/calendar_function.js?ver=2.5.18'></script>
<script type='text/javascript' src='http://poolmag.com/wp-content/plugins/spider-event-calendar/jscolor/jscolor.js?ver=2.5.18'></script>
<link rel='https://api.w.org/' href='http://poolmag.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://poolmag.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://poolmag.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='http://poolmag.com/?p=5753' />
<link rel="alternate" type="application/json+oembed" href="http://poolmag.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fpoolmag.com%2Fpredator-world-10-ball-rio-all-suites-hotel-casino-las-vegas-march-16-20%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://poolmag.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fpoolmag.com%2Fpredator-world-10-ball-rio-all-suites-hotel-casino-las-vegas-march-16-20%2F&#038;format=xml" />
<script data-cfasync="false" type="text/javascript">window.ec = window.ec || Object();
window.ec.config = window.ec.config || Object();
window.ec.config.enable_canonical_urls = true;
</script><script data-cfasync="false" type="text/javascript">
window.ec = window.ec || Object();
window.ec.config = window.ec.config || Object();
window.ec.config.store_main_page_url = 'http://poolmag.com/subscribe/';		
</script>  <script>
    var xx_cal_xx = '&';
  </script>
  <style type="text/css">/* Mailchimp for WP - Checkbox Styles */
.mc4wp-checkbox-wp-comment-form {
  clear: both;
  display: block;
  position: static;
  width: auto; }
  .mc4wp-checkbox-wp-comment-form input {
    float: none;
    width: auto;
    position: static;
    margin: 0 6px 0 0;
    padding: 0;
    vertical-align: middle;
    display: inline-block !important;
    max-width: 21px;
    -webkit-appearance: checkbox; }
  .mc4wp-checkbox-wp-comment-form label {
    float: none;
    display: block;
    cursor: pointer;
    width: auto;
    position: static;
    margin: 0 0 16px 0; }
</style>	<style type="text/css">
			#site-title,
		#site-description {
			position: absolute;
			clip: rect(1px, 1px, 1px, 1px);
		}
		</style>
	<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #2777c6; }
</style>
	</head>

<body class="post-template-default single single-post postid-5753 single-format-standard custom-background ">
<div id="page" class="hfeed site">
		<header id="masthead" class="site-header clearfix">

				<img src="http://poolmag.com/wp-content/uploads/2015/05/PoolBilliardHeader1.png" class="header-image" width="1280" height="416" alt="Pool &amp; Billiard Magazine">
	
		<div id="header-text-nav-container">
			<div class="inner-wrap">

				<div id="header-text-nav-wrap" class="clearfix">
					<div id="header-left-section">
												<div id="header-text">
							<h1 id="site-title">
								<a href="http://poolmag.com/" title="Pool &amp; Billiard Magazine" rel="home">Pool &amp; Billiard Magazine</a>
							</h1>
							<h2 id="site-description">The original monthly magazine for cue sports</h2><!-- #site-description -->
						</div><!-- #header-text -->
											</div><!-- #header-left-section -->
					<div id="header-right-section">
												<nav id="site-navigation" class="main-navigation" role="navigation">
							<h3 class="menu-toggle">Menu</h3>
							<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-28" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-28"><a href="http://poolmag.com/">Home</a></li>
<li id="menu-item-5146" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5146"><a href="https://simplecirc.com/subscribe/pool-billiard-magazine">SUBSCRIBE TODAY!</a></li>
<li id="menu-item-31" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31"><a href="http://poolmag.com/calendar/">Calendar</a></li>
<li id="menu-item-34" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34"><a href="http://poolmag.com/instruction/">Instruction</a></li>
<li id="menu-item-240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240"><a href="http://poolmag.com/game-rules/">Rules of the Games</a></li>
<li id="menu-item-573" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-573"><a href="http://poolmag.com/cool-pool-videos/">Cool Pool Videos</a></li>
<li id="menu-item-1792" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1792"><a href="http://poolmag.com/visit-our-advertisers/">Visit Our Advertisers</a></li>
<li id="menu-item-30" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30"><a href="http://poolmag.com/advertise/">Advertise</a></li>
<li id="menu-item-29" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-29"><a href="http://poolmag.com/about/">About</a>
<ul class="sub-menu">
	<li id="menu-item-562" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-562"><a href="http://poolmag.com/pb-covers/">P&#038;B Covers</a></li>
</ul>
</li>
<li id="menu-item-32" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32"><a href="http://poolmag.com/contact/">Contact</a></li>
</ul></div>						</nav>
			    	</div><!-- #header-right-section -->

			   </div><!-- #header-text-nav-wrap -->
			</div><!-- .inner-wrap -->
		</div><!-- #header-text-nav-container -->

		
						<div class="header-post-title-container clearfix">
					<div class="inner-wrap">
						<div class="post-title-wrapper">
													   	<h1 class="header-post-title-class">Predator World 10-Ball March 16-20</h1>
						   						</div>
											</div>
				</div>
				</header>
			<div id="main" class="clearfix">
		<div class="inner-wrap">
			
	<div id="primary">
		<div id="content" class="clearfix">
						
				
<article id="post-5753" class="post-5753 post type-post status-publish format-standard has-post-thumbnail hentry category-pool-and-billiard-tournament-news tag-predator-world-10-ball">
		<div class="entry-content clearfix">
		
<figure class="wp-block-image size-large"><img src="http://poolmag.com/wp-content/uploads/2020/02/PR-photo-1024x683.jpeg" alt="" class="wp-image-5754" srcset="http://poolmag.com/wp-content/uploads/2020/02/PR-photo-1024x683.jpeg 1024w, http://poolmag.com/wp-content/uploads/2020/02/PR-photo-300x200.jpeg 300w, http://poolmag.com/wp-content/uploads/2020/02/PR-photo-768x512.jpeg 768w, http://poolmag.com/wp-content/uploads/2020/02/PR-photo-640x427.jpeg 640w, http://poolmag.com/wp-content/uploads/2020/02/PR-photo.jpeg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption>Predator World 10-Ball, Rio All-Suites Hotel Casino, Las Vegas March 16-20</figcaption></figure>



<p>Predator World 10-Ball, Rio All-Suites Hotel Casino, Las Vegas March 16-20</p>



<p>Last year, Ping-Chung Ko claimed his first World Championship with a dramatic win in the finals over Joshua Filler. This was part of his incredible 2019, which earned him the WPA #1 ranking he has today.</p>



<p>In less than one month at the Rio All-Suites Hotel and Casino, he’ll have a chance to repeat. The $100,000 added tournament features 64 players in an impressively skilled field. Part of that is due to the appeal of 10-Ball, something Ko appreciates.</p>



<p>“I like 10-ball because it is more difficult to break. Although just one ball more it brings more diversity and visibility to enrich the game,” said Ko. “You need more concentration and more thorough consideration to finish each rack. I enjoy the feelings of playing 10-ball.”</p>



<p>Admission is free for the five-day competition and the event will be streamed live for no charge on Cuesports International’s YouTube channel. Last year’s event was the first Category 1 WPA sanctioned world championship held in the United States since 1997.</p>



<p>Players already confirmed and announced include Ko, former World 9-Ball Champion Joshua Filler, Billiard’s Digest player of the decade Shane Van Boening, Kremlin Cup winner Tyler Styer, 2017 World Games 9-Ball Champion Carlo Biado and reigning Mosconi Cup MVP Skyler Woodward.</p>



<p>More announcements will be made as we continue to finalize what is one of the most competitive fields of the year.</p>



<p>The Championship takes place over two stages. The first involves all players competing in a race to 8 matches in a double-elimination format until only 16 competitors remain. The surviving players then play in a single-elimination format during the second half of the event, with the race now increased to 10 games. The final phase features re-drawing of the brackets where competitors from the winner’s side take on players from the one-loss side.</p>



<p>The Predator World 10-ball Championship is presented by CueSports International and sponsored by Predator Group, the world’s premier cue makers and billiards accessory manufacturer. The event is being hosted at the Rio All-Suites Hotel and Casino and broadcasted live on YouTube by CSI Media, a subsidiary of CueSports International. For more information, visit&nbsp;<a href="http://www.world10ball.com/">www.world10ball.com</a>.<br><br>The Predator World 10-ball Championship is sponsored by:<br>Predator Cues:&nbsp;<a href="http://www.predatorcues.com/">www.predatorcues.com</a><br>CueSports International:&nbsp;<a href="https://www.playcsipool.com/">https://www.playcsipool.com</a>/<br>Diamond billiard tables:&nbsp;<a href="http://www.diamondbilliards.com/">www.diamondbilliards.com</a><br>Omega Billiards:&nbsp;<a href="http://www.omegabilliards.com/">www.omegabilliards.com</a><br>Kamui Brand:&nbsp;<a href="http://www.kamuibrand.com/">www.kamuibrand.com</a></p>



<p>Predator World 10-Ball, Rio All-Suites Hotel Casino, Las Vegas March 16-20</p>
<div class="extra-hatom-entry-title"><span class="entry-title">Predator World 10-Ball March 16-20</span></div><div class='shareaholic-canvas' data-app='share_buttons' data-title='Predator World 10-Ball March 16-20' data-link='http://poolmag.com/predator-world-10-ball-rio-all-suites-hotel-casino-las-vegas-march-16-20/' data-app-id='19003385' data-app-id-name='post_below_content'></div>				<div class="tags">
					Tagged on: <a href="http://poolmag.com/tag/predator-world-10-ball/" rel="tag">predator world 10-ball</a>				</div>
					</div>

	<footer class="entry-meta-bar clearfix">	        			
		<div class="entry-meta clearfix">
			<span class="by-author author vcard"><a class="url fn n" href="http://poolmag.com/author/haroldsimonsen/">Harold Simonsen</a></span>
			<span class="date updated"><a href="http://poolmag.com/predator-world-10-ball-rio-all-suites-hotel-casino-las-vegas-march-16-20/" title="7:10 am">February 21, 2020</a></span>
			       		<span class="category"><a href="http://poolmag.com/category/pool-and-billiard-tournament-news/" rel="category tag">Pool and Billiard Tournament News</a></span>
       					       			</div>
	</footer>
	</article>
				
		<ul class="default-wp-page clearfix">
			<li class="previous"><a href="http://poolmag.com/predator-pro-am-tour-stop-3-results/" rel="prev"><span class="meta-nav">&larr;</span> Predator Pro/Am Tour, Stop #3 Results</a></li>
			<li class="next"></li>
		</ul>
	
				
			
		</div><!-- #content -->
	</div><!-- #primary -->
	
	
<div id="secondary">
			
		<aside id="lfo_todays_date_widget-2" class="widget lfo_todays_date_widget_class"><h3 class="widget-title"><span>Today's Date</span></h3>Sunday, February 23 rd, 2020</aside><aside id="social-widget-2" class="widget Social_Widget"><h3 class="widget-title"><span>Connect with the P&#038;B Crew</span></h3><div class="socialmedia-buttons smw_left"><a href="https://www.facebook.com/PoolandBilliard" rel="nofollow" target="_blank"><img width="64" height="64" src="http://poolmag.com/wp-content/plugins/social-media-widget/images/default/64/facebook.png" 
				alt="Follow Us on Facebook" 
				title="Follow Us on Facebook" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="https://twitter.com/PoolandBilliard" rel="nofollow" target="_blank"><img width="64" height="64" src="http://poolmag.com/wp-content/plugins/social-media-widget/images/default/64/twitter.png" 
				alt="Follow Us on Twitter" 
				title="Follow Us on Twitter" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="https://www.pinterest.com/haroldsimonsen/pool-billiard-magazine-daily/" rel="nofollow" target="_blank"><img width="64" height="64" src="http://poolmag.com/wp-content/plugins/social-media-widget/images/default/64/pinterest.png" 
				alt="Follow Us on Pinterest" 
				title="Follow Us on Pinterest" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a><a href="https://www.youtube.com/channel/UCKdGzaPASe1doJ6bCsNzD-w?view_as=public" rel="nofollow" target="_blank"><img width="64" height="64" src="http://poolmag.com/wp-content/plugins/social-media-widget/images/default/64/youtube.png" 
				alt="Follow Us on YouTube" 
				title="Follow Us on YouTube" style="opacity: 0.8; -moz-opacity: 0.8;" class="fade" /></a></div></aside><aside id="text-10" class="widget widget_text">			<div class="textwidget"><h3><a href="https://mailchi.mp/8360fa1edb31/poolmag" target="_blank" rel="noopener noreferrer"><strong>SIGN UP HERE FOR FREE<br />
NEWS BETWEEN ISSUES!</strong></a></h3>
</div>
		</aside><aside id="text-7" class="widget widget_text"><h3 class="widget-title"><span>SUBSCRIBE NOW!</span></h3>			<div class="textwidget"><p><a href="https://simplecirc.com/subscribe/pool-billiard-magazine" target="_blank" rel="noopener noreferrer">Click on cover image to subscribe now!</a></p>
<p><a href="https://simplecirc.com/subscribe/pool-billiard-magazine"><img class="alignleft wp-image-5716 " src="http://poolmag.com/wp-content/uploads/2020/01/February-2020.png" alt="" width="300" height="401" /></a></p>
<p><span style="border-radius: 2px; text-indent: 20px; width: auto; padding: 0px 4px 0px 0px; text-align: center; font: bold 11px/20px 'Helvetica Neue',Helvetica,sans-serif; color: #ffffff; background: #bd081c no-repeat scroll 3px 50% / 14px 14px; position: absolute; opacity: 1; z-index: 8675309; display: none; cursor: pointer;">Save</span></p>
<p><span style="border-radius: 2px; text-indent: 20px; width: auto; padding: 0px 4px 0px 0px; text-align: center; font: bold 11px/20px 'Helvetica Neue',Helvetica,sans-serif; color: #ffffff; background: #bd081c no-repeat scroll 3px 50% / 14px 14px; position: absolute; opacity: 1; z-index: 8675309; display: none; cursor: pointer;">Save</span></p>
<p><span style="border-radius: 2px; text-indent: 20px; width: auto; padding: 0px 4px 0px 0px; text-align: center; font: bold 11px/20px 'Helvetica Neue',Helvetica,sans-serif; color: #ffffff; background: #bd081c no-repeat scroll 3px 50% / 14px 14px; position: absolute; opacity: 1; z-index: 8675309; display: none; cursor: pointer;">Save</span></p>
</div>
		</aside><aside id="text-8" class="widget widget_text">			<div class="textwidget"><br>
<br></div>
		</aside><aside id="text-11" class="widget widget_text">			<div class="textwidget"><p><a href="http://www.mcdermottcue.com/defy-high-performance-carbon-shaft.php?utm_source=PoolBilliard&amp;utm_medium=Banner&amp;utm_campaign=Defy" target="_blank" rel="noopener noreferrer"><img class="alignleft wp-image-5382 size-full" src="http://poolmag.com/wp-content/uploads/2019/08/mcd-defy-banner-300x150.gif" alt="" width="300" height="150" /></a></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p><a href="http://www.champbilliards.com/" target="_blank" rel="noopener noreferrer"><img class="alignleft wp-image-5383 size-full" src="http://poolmag.com/wp-content/uploads/2019/08/championship-billiards1.gif" alt="" width="300" height="150" /></a></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p><a href="https://www.pooldawg.com/?cjevent=044e7eec14bd11ea812f050f0a24060f"><img class="size-full wp-image-5575 alignleft" src="http://poolmag.com/wp-content/uploads/2019/12/Dawg-300x150.jpg" alt="" width="300" height="150" /></a></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p><a href="https://josscues.com/"><img class="size-full wp-image-5576 alignleft" src="http://poolmag.com/wp-content/uploads/2019/12/Joss.gif" alt="" width="300" height="150" /></a></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p><a href="https://www.predatorcues.com/shafts/vantage-shaft/"><img class="size-full wp-image-5577 alignleft" src="http://poolmag.com/wp-content/uploads/2019/12/vantage-300x150-banner-version2.gif" alt="" width="300" height="150" /></a></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p><a href="http://simoniscloth.com/"><img class="size-full wp-image-5578 alignleft" src="http://poolmag.com/wp-content/uploads/2019/12/Simonis-TPC_WEB.png" alt="" width="300" height="150" /></a></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p><a href="https://www.predatorcues.com/"><img class="size-full wp-image-5579 alignleft" src="http://poolmag.com/wp-content/uploads/2019/12/blak-300x150-banner-version1.gif" alt="" width="300" height="150" /></a></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p><a href="http://www.mcdermottcue.com/ipro-high-performance-shaft.php?utm_source=Direct&amp;utm_medium=Direct&amp;utm_campaign=iPro"><img class="size-full wp-image-5580 alignleft" src="http://poolmag.com/wp-content/uploads/2019/12/i-pro_pool-and-billiard_banner2.gif" alt="" width="300" height="150" /></a></p>
</div>
		</aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><br><br></div></aside>	</div>	
	

		</div><!-- .inner-wrap -->
	</div><!-- #main -->	
			<footer id="colophon" class="clearfix">	
			
	
			<div class="footer-socket-wrapper clearfix">
				<div class="inner-wrap">
					<div class="footer-socket-area">
						<nav class="small-menu clearfix">
									    			</nav>
					</div>
				</div>
			</div>			
		</footer>
		<a href="#masthead" id="scroll-up"></a>	
	</div><!-- #page -->
	<div class="custom-footer"><div id="footer_copyright-2" class="widget widget_footer_copyright"><div class="widget-wrap"><div class="footer-return return-center white"><a rel="nofollow" href="#" onclick="window.scrollTo(0,0); return false;" >Return To Top</a></div><div class="footer-putter-credits footer-center single"><div class="footer-putter-copyright white"><span class="copyright">Copyright &copy; 2020 Sports Publications Ltd. dba Pool & Billiard Magazine | Pool & Billiard Dealer | Pool & Billiard Daily</span></div><div class="footer-putter-contact white" ></div></div></div></div></div><!-- end .custom-footer --><link rel='stylesheet' id='Css-css'  href='http://poolmag.com/wp-content/plugins/spider-event-calendar/elements/calendar-jos.css?ver=2.5.18' type='text/css' media='' />
<script type='text/javascript' src='http://poolmag.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/poolmag.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='http://poolmag.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript' src='http://poolmag.com/wp-content/themes/spacious/js/navigation.js?ver=5.3.2'></script>
<script type='text/javascript' src='http://poolmag.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
</body>
</html>